CCNP Route FAQ: IPv4 and IPv6 Coexistence

CCNP Route FAQ: IPv4 and IPv6 Coexistence


Figure: Simple IPv4 Enterprise Network

Q1. An enterprise has plans to start adding IPv6 support. For the first year, the IPv6 will be in small pockets spread around the existing large IPv4 network, with occasional IPv6 traffic while applications teams test IPv6-enabled servers and applications. Which of the following tools would be most appropriate?
a. Native IPv6
b. Point-to-point tunnels
c. Multipoint tunnels
d. NAT-PT

Answer: C. Native IPv6 makes the most sense when the IPv6 deployment is pervasive, with traffic loads heavy or at least steady. Point-to-point tunnels work best when IPv6 is needed in only a subset of sites but also when the traffic should be somewhat regular or with higher volume. Multipoint tunnels also work well when IPv6 is needed in a subset of sites, but it is more appropriate when the traffic is more occasional and lower volume. Finally, NAT-PT is useful when an IPv4-only host needs to communicate with an IPv6-only host.

Q2. An enterprise has plans to start adding IPv6 support. The initial deployment requires support from some IPv6-only devices that need to access servers that support only IPv4. Which of the following tools would be most appropriate?
a. Native IPv6
b. Point-to-point tunnels
c. Multipoint tunnels
d. NAT-PT

Answer: D. Native IPv6 makes the most sense when the IPv6 deployment is pervasive, with traffic loads heavy or at least steady.. Point-to-point tunnels work best when IPv6 is needed in only a subset of sites, but also when the traffic should be somewhat regular or with higher volume. Multipoint tunnels also work well when IPv6 is needed in a subset of sites, but it is more appropriate when the traffic is more occasional and lower volume. Finally, NAT-PT is useful when an IPv4-only host needs to communicate with an IPv6-only host.

Q3. A client host uses IPv4 to communicate with one server and IPv6 to communicate with another. Which of the following IPv6 coexistence features is likely at work on the host?
a. Native IPv6
b. Point-to-point tunnels
c. Multipoint tunnels
d. NAT-PT
e. Dual stacks

Answer: E. Dual stacks means that the host runs both IPv4 and IPv6. A host must run both if the host is to send packets of each protocol. The host may use a multipoint tunnel, but the other three answers list features applicable to routers, but not hosts.

Q4. The following configuration exists on a router on one end of an IPv6 tunnel. Which type of tunnel is created by this configuration?
interface loopback 1
ip address 1.1.1.1 255.255.255.255
interface tunnel 2
ipv6 address 2000::1::/64
tunnel source loopback 1
tunnel destination 2.2.2.2
tunnel mode ipv6ip
ipv6 eigrp 1
a. Automatic 6to4
b. Manually configured tunnel
c. ISATAP
d. GRE

Answer: B. A manually configured tunnel explicitly defines the destination IPv4 address, as does a GRE IPv6 tunnel. The other two types listed in the answer do not. Additionally, a manually configured tunnel uses mode ipv6ip, whereas GRE tunnels use mode gre.

Q5. An engineer is reviewing another engineer’s sample configuration for a GRE tunnel used to pass IPv6 traffic. The tunnel has not yet been configured on the router. Which of the following commands is not required for the configuration to pass IPv6 traffic?
a. tunnel source
b. tunnel destination
c. tunnel mode
d. All these commands are required.

Answer: C. IOS defaults to use GRE encapsulation mode on tunnel interfaces, so the tunnel mode command is not required. The mode will default to GRE. The tunnel source and tunnel destination commands are required.

Q6. Which of the following IPv6 tunneling mechanisms support IPv6 IGP routing protocols? (Choose two.)
a. Automatic 6to4
b. Manually configured tunnel
c. ISATAP
d. GRE

Answer: B and D. The two point-to-point tunneling methods—manually configured tunnel and GRE—support IPv6 IGPs. The two multipoint tunneling methods—automatic 6to4 and ISATAP—do not.

Q7. The following configuration exists on a router on one end of an IPv6 tunnel. Although the configuration added so far is correct, the configuration is incomplete. Which type of tunnel is most likely to be intended by the network engineer?
interface loopback 1
ip address 192.168.1.1 255.255.255.255
interface tunnel 2
ipv6 address 2002:C0A8:101::1/64
tunnel source loopback 1
a. Automatic 6to4
b. Manually configured tunnel
c. ISATAP
d. GRE

Answer: A. An automatic 6to4 tunnel does not use a tunnel destination command on the tunnel interface; ISATAP tunnels also do not use this command. However, automatic 6to4 tunnels use IPv6 addresses that begin 2002::/16 and have the tunnel’s source IPv4 address imbedded as the second and third octets of the IPv6 address, whereas ISATAP tunnels do not. Because C0A5:101 hex equals 192.168.1.1 in dotted decimal, this configuration represents the almost completed configuration for an automatic 6to4 tunnel.

Q8. The answers each list a tunnel method and two consecutive IPv6 address quartets. Which answers identify a tunneling method that relies on an IPv4 address to be embedded into an IPv6 address, within the correct quartets listed? (Choose two.)
a. Automatic 6to4, quartets 2 and 3
b. Automatic 6to4, quartets 7 and 8
c. ISATAP, quartets 2 and 3
d. ISATAP, quartets 7 and 8

Answer: A and D. ISATAP uses a modified EUI-64 format, which adds the IPv4 address, in hex, into quartets 7 and 8. Automatic 6to4 tunnels use address range 2002::/16, with the next two quartets (second and third quartets) used to store the hex version of an IPv4 address.

Q9. Router R1 uses MAC address 1111.1111.1111 for its Fa0/0 interface. An engineer sees the following configuration in the output of a show running-config command. Then, the engineer issues a show ipv6 interface brief command. What global unicast IPv6 address does this command display for interface tunnel 1?
interface loopback 1
ip address 192.168.1.1 255.255.255.255
interface tunnel 1
tunnel source loopback 1
tunnel destination 192.168.1.2
tunnel mode ipv6ip isatap
ipv6 address 2000::/64 eui-64
a. 2000::1311:11FF:FE11:1111
b. 2000::C0A5:101
c. 2000:C0A5:101::
d. 2000::5EFE:C0A5:101

Answer: D. The combination of the configured eui-64 parameter on the ipv6 address command, and the tunnel mode of isatap, tells the router to use modified EUI-64 rules.
These rules start with the configured 64 bit prefix (2000::/64 in this case), adding 0000:5EFE as the fifth and sixth quartets. The last two quartets are taken from the tunnel source command’s referenced IPv4 address. In this case, 192.168.1.1 converts to C0A8:0101, making the last answer correct.

About the author

James Palmer

Leave a Comment