Windows 8.1 on Microsoft Surface Pro/Pro2 tablet issues after installing Pulse

Installing Pulse version 4.0R7 or 5.0R1 (supported on the Windows 8.1 OS) on a Microsoft Surface Pro or Pro2 is causing instability.

This issue can be revealed in several areas:

  • PnP (Plug and Play) devices not loading properly
  • All Network adapters missing, except the Juniper Networks Adapter
  • Touch interface unresponsive
  • Inability to log on to the device

Installing Junos Pulse 4.0R7 or 5.0R1 or 5.0R2 on a Microsoft Surface Pro or Pro2 is causing the device to become unstable.

Many hardware drivers are not loading properly, which can cause a number of issues:

  • several subsystems becoming unusable
  • a yellow warning icon appearing in the device manager list
  • network adapters becoming unusable
  • inability to log in/boot properly

In some situations, the only way to recover is to rebuild the operating system from scratch.

  • This issue affects only specific hardware: Windows Surface Pro/Pro 2 tablets (http://www.microsoft.com/surface/en-us/support/).
  • This issue exists only with the Windows 8.1 Operating System. The same hardware with Windows 8 works fine.
  • This issue is caused by several code changes in Windows 8.1, which expose a bug in the Windows API used by Pulse to manage network adapters.

This issue was resolved by Juniper in Pulse release 5.0R3 by upgrading the Juniper virtual adapter drivers from NDIS5 to NDIS6.

Please use only Pulse 5.0R3 or above when installing Pulse on a Surface Pro tablet running Windows 8.1 O.S.

About the author

Prasanna

Leave a Comment